Go Back   SolidHost Forums Sales Knowledgebase

Reply
 
Thread Tools Display Modes
Old Aug 18th, 2004, 11:06   #1
SH-Andre
SolidHost Crew
 
Join Date: Sep 2001
Posts: 850
Default Named problem

Question: with my new dedicated server with cpanel, when I try to enable the nameserver, I get an error that named is not running. Also when restarting named from WHM or shell, it tells me that named cannot be started. What can I do?

Answer: We have seen this problem many times before, and it appears to be a bug in the installation sequence of cPanel. The problem is that for some reason, it doesn't set up /etc/named.conf, so basically the DNS server's configuration file is missing. cPanel is working to get this fixed for the new release.

For now, if you have this problem, you can resolve this by doing the following:

Create an /etc/named.conf file with the following contents:
--

key "rndc-key" {
algorithm hmac-md5;
secret "";
};

controls {
inet 127.0.0.1 allow { localhost; } keys { "rndc-key"; };
};

zone "." {
type hint;
file "/var/named/named.ca";
};

--

Find the line in /etc/rndc.conf that contains "secret" and update the line in /etc/named.conf to be identical to that line in /etc/rndc.conf.

Restart named and run /usr/local/cpanel/cpkeyclt


This will resolve the problem. However if you are unsure how to do this, please contact support@solidrack.com, so we can do it for you.

-----------------
Andre van Vliet
SolidHost Administrators

Solid as a Rock
SH-Andre is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +2. The time now is 10:24.